Active Issue Alert – Payment Services - #000607676

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted May 16, 2025 - 14:19 EDT

Monitoring

We are aware of an issue reported by Apple impacting some transactions where the option to pay with Apple Pay is not available.

This issue is being monitored by Blackbaud.
Posted May 16, 2025 - 13:42 EDT
This incident affected: Payment Services.