Resolved Issue Alert – Education Management - 000259927
Incident Report for Blackbaud
Resolved
We identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues.

Our engineers have successfully implemented a fix and services are now restored. If you have any questions about status in the future, you can always get updates at this page.

Please continue to reference this page for updates.
Posted Jun 15, 2021 - 05:41 EDT
This incident affected: Blackbaud Education Management Solutions (Blackbaud Enrollment Management System, Blackbaud Learning Management System, Blackbaud Student Information System, Core Functionality, School API).