Active Issue Alert – Blackbaud Payment Service - #2019090901
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers when processing batch transactions is now resolved and services have been restored. Batches impacted during this incident that have a status of "Uploading data" can be reattempted. Batches in any other status such as "Gateway processing" should not be reattempted to avoid duplicates. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 9 days ago. Sep 11, 2019 - 19:03 EDT
Update
As previously reported, we have identified an issue impacting some of our customers processing batch transactions. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Customers may see their Transaction Batches stalled at "Uploading". If possible we recommend delaying batch processing until this issue is resolved. If you need to process a batch and experience this issue please contact support to verify the status of your batch. The next update will be provided at 9:00 AM EDT
Posted 9 days ago. Sep 11, 2019 - 16:48 EDT
Identified
We have identified an issue impacting some of our customers processing batch transactions. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Customers may see their Transaction Batches stalled at "Uploading". If possible we recommend delaying batch processing until this issue is resolved. If you need to process a batch and experience this issue please contact support to verify the status of your batch. The next update will be provided at 4:00 PM EDT
Posted 10 days ago. Sep 11, 2019 - 07:43 EDT
Update
We have identified an issue impacting some of our customers processing batch transactions. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Customers may see their Transaction Batches stalled at "Uploading". If possible we recommend delaying batch processing until this issue is resolved. If you need to process a batch and experience this issue please contact support to verify the status of your batch. The next update will be provided at 9:00 AM EDT
Posted 10 days ago. Sep 10, 2019 - 19:03 EDT
Update
We have identified an issue impacting some of our customers processing batch transactions. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Customers may see their Transaction Batches stalled at "Uploading". If possible we recommend delaying batch processing until this issue is resolved. If you need to process a batch and experience this issue please contact support to verify the status of your batch.
Posted 11 days ago. Sep 09, 2019 - 17:52 EDT
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Customers may see their Transaction Batches stalled at "Uploading". Please contact customer support before retrying the batches.
Posted 12 days ago. Sep 09, 2019 - 09:27 EDT
Investigating
We have identified an issue impacting some of our customers. Customers may see their Transaction Batches stalled at "Uploading". Please contact customer support before retrying the batches.
Posted 12 days ago. Sep 09, 2019 - 07:06 EDT
This incident affected: Blackbaud Payment Service.