Active Issue Alert – Financial Edge NXT - #000086418
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Nov 12, 2019 - 11:57 EST
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Nov 12, 2019 - 11:33 EST
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Nov 12, 2019 - 10:53 EST
This incident affected: Financial Edge NXT (Financial Edge NXT).