Engineers have resolved the issue causing incorrect information to appear in invoices. Users are again able to access invoices. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Sep 05, 2024 - 13:52 EDT
Identified
We recently discovered an invoicing issue that affected schools that use Blackbaud Tuition Management. Invoice links within the parent portal were linking to incorrect invoices. We have stopped generating all invoices and rolled back the change which caused this issue. We are working on generating correct invoice links and updating the links within the parent portal.
Posted Sep 05, 2024 - 13:43 EDT
Update
We are aware of an issue where invoices may not be available to view. Engineers are working to address the issue as soon as possible. Please continue to reference this page for updates.
Posted Sep 05, 2024 - 13:04 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Sep 05, 2024 - 11:52 EDT
This incident affected: Blackbaud Tuition Management™.