An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jan 14, 2026 - 11:17 EST
Investigating
We are investigating reports of users that are unable to see submitted gifts which need to be matched to constituents in the Online Data Review module. Our engineers are diagnosing the cause so that we can resolve this for you as quickly as possible. Please continue to reference this page for updates.
Posted Jan 14, 2026 - 10:09 EST
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).