Active Issue Alert – Email Services - #000593507

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 11:41 EDT

Investigating

We have identified an issue impacting the reporting of bounce data for email jobs. Email sending is not impacted. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 17, 2025 - 11:28 EDT
This incident affected: Email Services.