Active Issue Alert – Blackbaud Tuition Management™ - #000596039

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted 5 days ago. Mar 27, 2025 - 08:13 EDT

Investigating

We are aware that subset of our Payment Services or Merchant Services customers are experiencing an issue when processing transactions. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted 5 days ago. Mar 27, 2025 - 08:12 EDT
This incident affected: Payment Services.