Active Issue Alert – Blackbaud Learning Management - 000614817

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 18:09 EDT

Update

We are currently investigating an issue impacting Teacher and Administration navigation on Academic group pages. Some tabs are inaccessible.
Posted Jun 18, 2025 - 16:11 EDT

Update

We are continuing to investigate this issue.
Posted Jun 18, 2025 - 16:10 EDT

Investigating

We are investigating an issue impacting some of our customers. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jun 18, 2025 - 15:59 EDT
This incident affected: Blackbaud Education Management Solutions (Blackbaud Learning Management System).