We have made a configuration change based our findings and are observing latency and errors decrease. We will transition this incident into a monitoring status to ensure continued stability. Please continue to reference this page for updates.
Posted May 01, 2026 - 16:09 EDT
Update
A subset of customers are experiencing intermittent latency and/or errors when working in Web view. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible.
Posted May 01, 2026 - 13:56 EDT
Update
A subset of customers are experiencing intermittent latency and/or errors when working in Web view. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible.
Posted May 01, 2026 - 13:18 EDT
Update
A subset of customers are experiencing intermittent latency and/or errors when working in Web view. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible.
Posted May 01, 2026 - 13:14 EDT
Update
We are continuing to investigate this issue.
Posted May 01, 2026 - 13:05 EDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted May 01, 2026 - 12:58 EDT
This incident affects: Blackbaud Financial Edge NXT® (Financial Edge NXT) and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).