Active Issue Alert – BBPS - 000601452

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Apr 20, 2025 - 02:13 EDT

Identified

We are investigating an issue impacting some of our customers. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 20, 2025 - 01:57 EDT
This incident affected: Payment Services.