Active Issue Alert – Blackbaud University - #000683956

Incident Report for Blackbaud

Identified

We are aware of an issue impacting a subset of customers when attempting to access Blackbaud University at LEARN.BLACKBAUD.COM ; Our engineers have identified the cause and are working on a solution to this issue, the next update will be Monday 7/20 by Noon ET.
Posted Jul 17, 2026 - 16:35 EDT

Investigating

We are aware of an issue impacting a subset of customers when attempting to access Blackbaud University at LEARN.BLACKBAUD.COM ; Our engineers are investigating this issue and next update will be tomorrow by 5PM ET.
Posted Jul 16, 2026 - 17:33 EDT
This incident affects: Blackbaud.com (Blackbaud.com).