Resolved Issue Alert – Online Express - #000083520
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 01, 2019 - 07:34 EDT
This incident affected: Online Express (Online Express).