Resolved Issue Alert – Blackbaud Merchant Services - #000086858
Incident Report for Blackbaud
Resolved
We have identified an issue with processing direct debit transactions which caused transactions processed between Sunday, November 10th at 4:30AM EST and Tuesday, November November 12th at 12:40PM EST to enter a state of "Validation Error" with a result message of "General System Failure". At this time please do not reprocess direct debit transactions that failed with this error during this window until we are able to determine the results of these charges.
Posted Nov 13, 2019 - 11:34 EST
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™).