Active Issue Alert – Raiser's Edge NXT - #000596649

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Mar 29, 2025 - 14:23 EDT

Identified

We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Mar 29, 2025 - 13:53 EDT

Investigating

We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 29, 2025 - 12:49 EDT
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).