Active Issue Alert – Blackbaud Financial Edge NXT® - #000684971

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 15:16 EDT

Identified

We have confirmed a subset of customers are located in a vendor region currently experiencing issues with network traffic traversal. Our engineers are currently engaged with our vendor and working towards a resolution. Please continue to monitor this page for the latest updates.
Posted Jul 23, 2026 - 12:49 EDT

Investigating

We are aware of an issue impacting a subset of FENXT customers that may cause modules to be unavailable and HTTP Failure Response errors to occur. Our engineering team is actively investigating and working toward a resolution. Please continue to monitor this page for the latest updates.
Posted Jul 23, 2026 - 11:45 EDT
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT).