Active Issue Alert – Blackbaud Payment Services - #2017101801
Incident Report for Blackbaud
Resolved
We have confirmed services remain stable and transactions continue to process successfully. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Oct 18, 2017 - 11:48 EDT
Monitoring
A subset of customers may have received an error message when attempting to receive or process payment transactions. This event lasted for approximately 20 minutes. Your services are now fully restored and transactions are now processing. We are monitoring services for the next two hours to ensure the issue does not recur. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Oct 18, 2017 - 09:37 EDT
Investigating
We are aware that some of our Payment Services or Merchant Services customers are experiencing an issue when processing transactions. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Oct 18, 2017 - 08:57 EDT