An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Sep 28, 2023 - 14:20 EDT
Update
We identified an issue that is preventing locally-hosted users from downloading the Online Express install files from the Online Express download page. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates. Please refer to https://kb.blackbaud.com/knowledgebase/articles/Article/202622 for a workaround solution.
Posted Sep 27, 2023 - 14:01 EDT
Update
We identified an issue that is preventing locally-hosted users from downloading the Online Express install files from the Online Express download page. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates. Please refer to https://kb.blackbaud.com/knowledgebase/articles/Article/202622 for a workaround solution.
Posted Sep 26, 2023 - 12:24 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Sep 26, 2023 - 09:21 EDT
This incident affected: Blackbaud Online Express™ (Blackbaud Online Express™).