Active Issue Alert – Raiser's Edge NXT / Financial Edge NXT #000607203

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted May 15, 2025 - 04:33 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 02:22 EDT

Identified

We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully diagnosed the issue and have all the appropriate engineers working to address it for you. We hope to have your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted May 15, 2025 - 01:57 EDT

Investigating

We are investigating an issue impacting some of our customers. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted May 15, 2025 - 01:21 EDT
This incident affected: Blackbaud Altru®, Blackbaud Financial Edge NXT® (Financial Edge NXT), and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).