Active Issue Alert – Financial Edge, Financial Edge NXT - 000367582
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jun 21, 2022 - 15:10 EDT
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors, or access issues. Users may not be able to access database view. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jun 21, 2022 - 14:44 EDT
Update
We are continuing to investigate this issue.
Posted Jun 21, 2022 - 14:23 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jun 21, 2022 - 14:17 EDT
This incident affected: Financial Edge NXT (Financial Edge NXT) and Financial Edge.