Maintenance Overage 000456177 - Multiple Services Affected

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted May 24, 2023 - 00:46 EDT

Update

We are continuing to investigate this issue.
Posted May 24, 2023 - 00:46 EDT

Investigating

We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted May 23, 2023 - 23:37 EDT

Identified

Maintenance ID 63360 - The maintenance that was scheduled to complete on 5/25/2023 at 10 PM EST has been extended to 12:00AM EST.
This maintenance is necessary to perform a routine maintenance task in our environment
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted May 23, 2023 - 21:28 EDT
This incident affected: Blackbaud CRM™, Blackbaud Internet Solutions™, and Blackbaud NetCommunity™.