Resolved Issue Alert – Blackbaud Award Management - #000083319
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Oct 31, 2019 - 12:55 EDT
This incident affected: Blackbaud Award Management (formerly AcademicWorks).