Active Issue Alert – Blackbaud Altru® - #000691526

Incident Report for Blackbaud

Resolved

An issue impacting some customers that was causing unresolved order errors for Diner's Club and American Express transactions has been resolved.
Posted Sep 03, 2026 - 16:59 EDT

Investigating

We have identified an issue impacting some customers that is causing unresolved order errors for Diner's Club and American Express transactions. Our engineers are actively investigating and working to resolve the issue. Please continue to check this page for updates.
Posted Sep 03, 2026 - 13:39 EDT
This incident affected: Blackbaud Altru®.