Active Issue Alert – Blackbaud Website - 000258162
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 08:22 EDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jun 08, 2021 - 08:22 EDT
This incident affected: Blackbaud Website Package.