Active Issue Alert – Multiple Products - 000557681
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Oct 03, 2024 - 17:51 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 03, 2024 - 17:50 EDT
Update
We are investigating reports of "error status code 409: Conflict" when attempting to process donations or registrations. Our engineers are working to resolve it quickly. Please continue to reference this page for updates.
Posted Oct 03, 2024 - 17:24 EDT
Update
We are investigating reports of "error status code 409: Conflict" when attempting to process donations or registrations. Our engineers are working to resolve it quickly. Please continue to reference this page for updates.
Posted Oct 03, 2024 - 17:18 EDT
Identified
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause and we have all the appropriate engineers available to get your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Oct 03, 2024 - 17:06 EDT
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT), Blackbaud Luminate Online® (Blackbaud Luminate Online®), Blackbaud Education Management Solutions (Blackbaud Billing Management™), and Payment Services.