Active Issue Alert – Luminate Online - #000691216

Incident Report for Blackbaud

Resolved

An issue impacting a subset of customers and their access to ITC/DEV sites has been resolved
Posted Sep 02, 2026 - 10:17 EDT

Investigating

We have identified an issue impacting a subset of customers access their ITC/DEV sites. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Sep 02, 2026 - 09:52 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).