Resolved Issue Alert – Financial Edge NXT and Raiser's Edge NXT - 000395976
Incident Report for Blackbaud
Resolved
We identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues.

Our engineers have successfully implemented a fix and services are now restored. If you have any questions about status in the future, you can always get updates at this page.

Please continue to reference this page for updates.
Posted Sep 29, 2022 - 08:20 EDT
This incident affected: Financial Edge NXT (Financial Edge NXT) and Raiser's Edge NXT (Raiser's Edge NXT).