Active Issue Alert – Blackbaud Altru® - #000523699
Incident Report for Blackbaud
Resolved
An issue impacting a subset of our customers should now be resolved and services should be restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Apr 17, 2024 - 13:52 EDT
Update
An issue impacting some of our customers should now be resolved and services should be restored. Our Engineers are continuing to monitor. If you have any questions about status in the future, you can always get updates at this page. Next updates will be on 4/17 at 2:00 PM ET.
Posted Apr 17, 2024 - 10:07 EDT
Monitoring
An issue impacting some of our customers should now be resolved and services should be restored. Our Engineers are continuing to monitor overnight. If you have any questions about status in the future, you can always get updates at this page. Next update 4/17 at 10:30 AM ET.
Posted Apr 16, 2024 - 18:20 EDT
Update
A subset of users are receiving the following error in different areas of the application. "Error: An unknown error occurred during the request. This could indicate a request to an invalid endpoint." Our engineers are still investigating the issue and are working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 16, 2024 - 16:55 EDT
Update
While actively working on this issue, we've noted that some users began reporting timeout errors or "This page cannot be reached" on Tuesday around 2 PM EDT. We are seeing this clear for most users now so please try refreshing or logging in again. Our engineers continue diagnosing the event and working to resolve it for you. Please continue to reference this page for updates.
Posted Apr 16, 2024 - 14:45 EDT
Update
A subset of users are receiving the following error in different areas of the application. "Error: An unknown error occurred during the request. This could indicate a request to an invalid endpoint."
Our engineers are still investigating the issue and are working to resolve it for you as quickly as possible. Please continue to reference this page for updates. The next update for this issue will be provided by 5:00 PM EDT.
Posted Apr 16, 2024 - 14:06 EDT
Investigating
A subset of users are receiving the following error in different areas of the application. "Error: An unknown error occurred during the request. This could indicate a request to an invalid endpoint."
Our engineers are continuing to investigate and are working to resolve it for you as quickly as possible. Please continue to reference this page for updates. The next update for this issue will be provided by 2:00 PM EDT.
Posted Apr 16, 2024 - 09:56 EDT
Monitoring
A subset of users are receiving the following error in different areas of the application. "Error: An unknown error occurred during the request. This could indicate a request to an invalid endpoint."
Our engineers are diagnosing the event and working to resolve it for you. Please continue to reference this page for updates.
Posted Apr 15, 2024 - 20:55 EDT
Update
A subset of users are receiving the following error in different areas of the application. "Error: An unknown error occurred during the request. This could indicate a request to an invalid endpoint."
Our engineers are diagnosing the event and working to resolve it for you. Please continue to reference this page for updates.
Posted Apr 15, 2024 - 13:32 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 15, 2024 - 11:09 EDT
This incident affected: Blackbaud Altru®.