Active Issue Alert – Blackbaud Payment Services - #000117354
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Mar 15, 2020 - 01:45 EDT
Update
As previously reported, we have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues when attempting to utilize the impacted product below. Our engineers have successfully identified & diagnosed the issue, and we are working to address it now. We appreciate your patience during this time. Please continue to reference this page for updates. Next update will be provided at 2:30 AM EST or as more information becomes available.
Posted Mar 15, 2020 - 00:37 EDT
Update
As previously reported, we have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully identified & diagnosed the issue, and we are working to address it now. We appreciate your patience during this time. Please continue to reference this page for updates.
Posted Mar 14, 2020 - 23:36 EDT
Update
As previously reported, we have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully identified & diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Mar 14, 2020 - 22:54 EDT
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Mar 14, 2020 - 22:12 EDT
Identified
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Mar 14, 2020 - 22:02 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 14, 2020 - 21:45 EDT
This incident affected: Blackbaud Payment Service.