An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Apr 08, 2025 - 09:23 EDT
Identified
When navigating in the portal, some pages will not load completely. We hope to have your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Apr 08, 2025 - 08:31 EDT
Investigating
When accessing student records via People finder in Academics users receive a "Head's up! You're in a restricted area". Please continue to reference this page for updates.
Posted Apr 08, 2025 - 07:09 EDT
This incident affected: Blackbaud Education Management Solutions (Blackbaud Student Information System™).