Active Issue Alert – JustGiving - #000597693

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 05:15 EDT

Update

We have identified an issue impacting some of our customers, causing 502 errors when attempting to reset passwords. Our engineers are diagnosing the event and working to resolve it as quickly as possible. Please continue to reference this page for updates.
Posted Apr 03, 2025 - 04:30 EDT

Investigating

We are investigating an issue impacting some of our customers. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 03, 2025 - 04:18 EDT
This incident affected: JustGiving® from Blackbaud®.