Our engineers have resolved an issue causing admins to receive an error when viewing TeamRaiser participants and gifts. We recommend that you logout of your Luminate Online site and log back in to view the participant or gift again. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Mar 19, 2025 - 12:20 EDT
Investigating
We have identified an issue causing some customers to experience an error when attempting to view some TeamRaiser gifts or participants. Our engineers are working to diagnose the issue and resolve it for you as quickly as possible.
Posted Mar 19, 2025 - 11:38 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).