Resolved Issue Alert – Blackbaud Tuition Management and Financial Aid Management Operational - #000090745
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 28, 2019 - 11:39 EST
This incident affected: Blackbaud Financial Aid Management and Blackbaud Tuition Management.