Active Issue Alert – Church Management - 000151033
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jul 20, 2020 - 12:14 EDT
Update
We are continuing to investigate this issue.
Posted Jul 20, 2020 - 12:12 EDT
Investigating
We are currently investigating this issue.
Posted Jul 20, 2020 - 12:00 EDT
This incident affected: Blackbaud Church Management.