Active Issue Alert – Blackbaud Tuition Management - #000586131

Incident Report for Blackbaud

Resolved

An issue impacting a small subset of our customers causing issues with the shopping cart is now resolved and service has been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Feb 12, 2025 - 17:44 EST

Investigating

We have identified an issue impacting a small subset of our customers causing issues with the shopping cart. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Feb 12, 2025 - 17:01 EST
This incident affected: Blackbaud Tuition Management™.