Active Issue Alert – Blackbaud Luminate Online® - #000645572

Incident Report for Blackbaud

Resolved

An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 13, 2025 - 16:46 EST

Identified

Our engineers have identified a fix and are working quickly to get this resolution deployed for impacted customers. Please continue to reference this page for updates
Posted Nov 13, 2025 - 15:56 EST

Investigating

We have identified an issue impacting donation forms that can cause an error if the form is configured to use the "billing information is same as donor information" option. Admins can prevent the error by temporarily disabling or removing this option. Donors can work around this by unchecking the box and filling out all billing fields. Our engineers are working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Nov 13, 2025 - 11:54 EST
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).