Active Issue Alert – Blackbaud CRM, Blackbaud NetCommunity, Raiser's Edge, Financial Edge - 000540337
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 23:39 EDT
Update
We are continuing to investigate this issue.
Posted Jul 18, 2024 - 22:41 EDT
Update
We are seeing intermittent issues across multiple products caused by a vendor outage. We are working with our vendor to resolve these issues. Further updates will be provided as they become available.
Posted Jul 18, 2024 - 21:00 EDT
Update
We are continuing to investigate this issue.
Posted Jul 18, 2024 - 19:54 EDT
Investigating
A major internet outage is affecting Blackbaud product availability. Further updates will be provided as they become available.
Posted Jul 18, 2024 - 19:46 EDT
This incident affected: Blackbaud Grantmaking™ (Blackbaud Grantmaking™), Blackbaud Financial Edge NXT® (Financial Edge NXT), Blackbaud CRM™, Financial Edge®, Raiser's Edge®, and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).