Active Issue Alert – Blackbaud Luminate Online® - #000630275

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 18:15 EDT

Update

Our engineers have resolved the Technical Difficulties errors on user pages impacting a subset of customers. Additionally, they have identified a fix for the iATS errors and are working to deploy these changes this evening.
Posted Aug 27, 2025 - 16:17 EDT

Update

We have identified an additional issue that is causing a Technical Difficulties error for a subset of customers sites, including user pages and forms. Our engineers are currently diagnosing this event and working to resolve it as quickly as possible.
Posted Aug 27, 2025 - 15:56 EDT

Identified

We have identified an additional issue that is causing a Technical Difficulties error for a subset of customers while navigating the admin side. Our engineers are currently diagnosing this event and working to resolve it as quickly as possible.

We continue to diagnose the iATS issue for those customers.
Posted Aug 27, 2025 - 15:44 EDT

Investigating

We have identified an issue impacting a subset of customers using iATS payment processing, resulting in payment and refund errors. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Aug 27, 2025 - 10:35 EDT
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).