Active Issue Alert – Luminate online - 000643440

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 13:00 EST

Monitoring

Our engineers have made a change, and we've seen no further errors. We will continue to monitor. If you have email messages that remain in a "stuck" status, you will need to cancel the email message and resend it to ensure successful delivery.
Posted Nov 03, 2025 - 11:41 EST

Investigating

We have identified an intermittent issue that is causing email campaign status to be stuck in "Generating Audience" or "Sending". Our engineers are working to diagnose and resolve the issue as quickly as possible. Please continue to check this page for updates.
Posted Nov 03, 2025 - 10:37 EST
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®).