Maintenance Overage 20072501300567 - Blackbaud NetCommunity
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Aug 02, 2020 - 14:00 EDT
Identified
Maintenance ID 20072501300567- The maintenance that was scheduled to complete on 08/02/2020 at 12:00 PM has been extended to 2:00 PM.
This maintenance is necessary to Update Blackbaud NetCommunity sites.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Aug 02, 2020 - 12:07 EDT
This incident affected: Blackbaud NetCommunity.