Active Issue Alert – Education Management - #000651880

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Dec 23, 2025 - 20:01 EST

Identified

We are aware of an issue preventing photo content from uploading to the application, and our teams are actively working on a resolution.
Posted Dec 23, 2025 - 16:38 EST
This incident affected: Blackbaud Education Management Solutions (Core Functionality).