Grateful Patient Service - 000618897

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 10:47 EDT

Investigating

We are currently investigating an issue preventing Grateful Patient Service files from being retrieved for processing.
Posted Jul 09, 2025 - 10:21 EDT
This incident affected: Grateful Patient Solution.