Active Issue Alert – Multiple Products Affected - #000633959

Incident Report for Blackbaud

Update

We temporarily suspended the DeceasedRecordFinder™ and AddressFinder™ services within all Blackbaud solutions due to an issue with one of our vendors. We are continuing to work with our vendor who enables these services to resolve this issue and will notify you when these services can resume. Please continue to reference this page for updates.
Posted Sep 15, 2025 - 16:27 EDT

Update

We are aware that a subset of customers are not receiving Address Finder or Deceased Finder record/file updates. Updates have been paused while our engineers diagnose the cause in order to resolve this issue as quickly as possible for you. Please continue to reference this page for updates.
Posted Sep 15, 2025 - 13:53 EDT

Update

We are aware that a subset of customers are not receiving Address Finder or Deceased Finder record/file updates. Updates have been paused while our engineers diagnose the cause in order to resolve this issue as quickly as possible for you. Please continue to reference this page for updates.
Posted Sep 15, 2025 - 11:09 EDT

Update

We are continuing to investigate this issue.
Posted Sep 15, 2025 - 10:40 EDT

Update

We are continuing to investigate this issue.
Posted Sep 15, 2025 - 10:37 EDT

Update

We are continuing to investigate this issue.
Posted Sep 15, 2025 - 10:35 EDT

Investigating

We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Sep 15, 2025 - 10:31 EDT
This incident affects: Blackbaud Altru®, Blackbaud CRM™, Blackbaud eTapestry® and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).