Active Issue Alert – Luminate Online- 000286194
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 03:05 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Sep 15, 2021 - 02:08 EDT
This incident affected: Luminate (Luminate Online).