Active Issue Alert – Blackbaud CRM™ - 000539847
Incident Report for Blackbaud
Resolved
An issue impacting a subset of our customers causing errors when calling business processes is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jul 17, 2024 - 12:04 EDT
Investigating
We have identified an issue impacting a subset of our customers causing errors when calling business processes. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 17, 2024 - 11:19 EDT
This incident affected: Blackbaud CRM™.