Active Issue Alert – Blackbaud Merchant Services – Single Product - #000117335
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Mar 13, 2020 - 20:36 EDT
Identified
Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Mar 13, 2020 - 20:25 EDT
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Mar 13, 2020 - 19:51 EDT
Update
We are continuing to investigate this issue.
Posted Mar 13, 2020 - 19:50 EDT
Update
We are continuing to investigate this issue.
Posted Mar 13, 2020 - 19:49 EDT
Investigating
We are currently investigating this issue.
Posted Mar 13, 2020 - 19:49 EDT
This incident affected: Blackbaud Payment Service.