Maintenance Overage 22080805495279 - Blackbaud NetCommunity
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Aug 17, 2022 - 03:42 EDT
Identified
Maintenance ID 22080805495279- The maintenance that was scheduled to complete on 8/17/2022] at 3:00:00 AM has been extended to 4:00:00 AM

Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Aug 17, 2022 - 03:03 EDT
This incident affected: Blackbaud NetCommunity™.