Active Issue Alert – Financial Edge NXT - 000540149
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jul 23, 2024 - 10:47 EDT
Update
Our engineers have determined the root cause and are currently working on a fix. The expected release for the fix is set for Monday night. In the interim, users are able to process computer checks with signatures within database view.

The next status update will be on 7/22/2024.
Posted Jul 19, 2024 - 15:56 EDT
Identified
Our engineers have determined the root cause and are currently working on a fix. The expected release for the fix is set for Friday evening. In the interim, users are able to process computer checks with signatures within database view. The next status update will be on 7/19/2024.
Posted Jul 18, 2024 - 15:15 EDT
Update
We have identified an issue with electronic signatures not printing in Financial Edge NXT. Users are still able to process computer checks with electronic signatures within database view. Our engineers are diagnosing the event and working to resolve it as quickly as possible. Please continue to reference this page for updates.
Posted Jul 18, 2024 - 10:45 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 18, 2024 - 10:39 EDT
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT, Treasury API).