Active Issue Alert – Raiser's Edge NXT - 000527520
Incident Report for Blackbaud
Resolved
An issue impacting a subset of customers where donation forms may not load is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted May 01, 2024 - 12:18 EDT
Investigating
We have identified an issue where a subset of customers are experiencing an issue where donation forms may not load. We are actively working on a fix and will have it implemented as soon as possible. Please continue to reference this page for updates.
Posted May 01, 2024 - 11:02 EDT
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).