Active Issue Alert – Blackbaud Altru #000578256
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jan 21, 2025 - 08:35 EST
Update
We are currently finalizing restoration of impacted job schedules. To ensure minimal disruption, we are planning to deploy the fix on the night of Friday, 1-17. As a reminder, users may still manually run processes impacted by this issue. We have no further updates planned at this time, though we will update this page when the issue is resolved.
Posted Jan 16, 2025 - 09:08 EST
Update
We have identified the cause of this issue and are working to restore the job schedules of impacted customers, which we currently expect to be complete by tomorrow. As a reminder, users may still manually run processes impacted by this issue. Please reference this page for updates, the next of which will be no later than 11 AM EST Thursday morning.
Posted Jan 15, 2025 - 10:46 EST
Identified
We have identified an issue impacting a small subset of customers where scheduled jobs are not running. As a workaround, users may manually run the processes. Our engineers are working to restore job schedules for impacted customers. Please reference this page for updates, the next of which will be no later than 10 AM EST Wednesday morning.
Posted Jan 14, 2025 - 12:00 EST
This incident affected: Blackbaud Altru®.